I understand that, but I don't see why we need two different ways to
modify them -- you can redefine the standard bitmap directly, so I
don't see why do we need an extra level of indirection here (which has
to be done at the C level to an already quite complex piece of code).
Currently, what we have are standard bitmaps for "bob-left",
"bob-right", "eob-left", "eob-right" etc...
But, rather than following the existing pattern of naming them after
their purpose (like "continuation-line", "left-truncation" etc), I
have named them after their visual appearence, e.g. "top-left-angle",
"top-right-angle", "bottom-left-angle", etc...
That is a bug IMO, so I agree with Miles that those names should be
changed to match their purpose rather their appearence.
I would not say we "need" the extra level--that word is too
strong--but I think it would be cleaner.
It would be cleaner to name each bitmap after what it looks like, such
as top-left-angle, then specify by name one of these bitmaps to use
for a given purpose, such as beginning-of-buffer.
It's like defining a function with your own choice of name and then
putting that name in a hook or variable with a standard fixed name,
instead of redefining a function with a fixed name.