For a new name for "New File", recent discussion has included candidates
Visit New File and New File Buffer.
As I said in my original post, which started this, the problem here is
"New". The best name for this Emacs operation is, as in the past, "Open". I
gave reasons previously.
The problem then is distinguishing this from opening an existing file
*only*. For that, I suggested that "Open File" would be sufficient, since
"file" implies an existing file - you cannot open a new file; you can only
create a new file.
If people don't think that "Open File" sufficiently makes this clear, then
let's call it "Open Existing File" to remove all doubt. The two menu items
would then be:
- "Open Existing File" = create/select a buffer for an
- "Open" = new or existing: "Open Existing File" or
create a buffer for a new file.
However, as I mentioned, to be consistent, "Open Directory" and "Insert
File" should then also be renamed "Open Existing Directory" and "Insert
I personally think that the following sufficiently suggest existing objects:
"Open File", "Open Directory", and "Insert File". But if people prefer "Open
Existing File" to "Open File", then we have the choice of opting for
consistency, using "Existing" for the others also, or inconsistency, using
it only for "Open Existing File".